hi @renaud I can't seem to make sense of why your python installation will not instal pyserial.

From the output you provided:

Reading http://pypi.python.org/simple/pyserial/

The link works - so easy_install should be able to find the package.

Well, perhaps you need to upgrade from Mavericks to something newer - or you could try to install pyserial manually here: Pyserial