Installation issue on Mac OS 10.9.5



  • Hello,

    I got an error during the installation of OpenMono-v1.7.3-Mac.pkg on OS-10.9.5

    Any idea how to fix it?

    Thank you in advance,
    Renaud

    Installer log:

    Oct  5 09:41:35 mbp-renaud-3 Installer[46985]: LSExceptions [0x7f9dda408f00] loaded
    Oct  5 09:41:35 mbp-renaud-3 Installer[46985]: @(#)PROGRAM:Install  PROJECT:Install-847
    Oct  5 09:41:35 mbp-renaud-3 Installer[46985]: @(#)PROGRAM:Installer  PROJECT:Installer-721
    Oct  5 09:41:35 mbp-renaud-3 Installer[46985]: Hardware: MacBookPro11,3 @ 2.50 GHz (x 8), 16384 MB RAM
    Oct  5 09:41:35 mbp-renaud-3 Installer[46985]: Running OS Build: Mac OS X 10.9.5 (13F1712)
    Oct  5 09:41:35 mbp-renaud-3 Installer[46985]: Env: PATH=/usr/bin:/bin:/usr/sbin:/sbin
    Oct  5 09:41:35 mbp-renaud-3 Installer[46985]: Env: TMPDIR=/var/folders/vt/kc9wgclx3jv0z0_0s83f9b8m0000gn/T/
    Oct  5 09:41:35 mbp-renaud-3 Installer[46985]: Env: SHELL=/bin/bash
    Oct  5 09:41:35 mbp-renaud-3 Installer[46985]: Env: HOME=/Users/Admin
    Oct  5 09:41:35 mbp-renaud-3 Installer[46985]: Env: USER=Admin
    Oct  5 09:41:35 mbp-renaud-3 Installer[46985]: Env: LOGNAME=Admin
    Oct  5 09:41:35 mbp-renaud-3 Installer[46985]: Env: SSH_AUTH_SOCK=/tmp/launch-9YUuXs/Listeners
    Oct  5 09:41:35 mbp-renaud-3 Installer[46985]: Env: Apple_PubSub_Socket_Render=/tmp/launch-aD9J9h/Render
    Oct  5 09:41:35 mbp-renaud-3 Installer[46985]: Env: DISPLAY=/tmp/launch-8LDLIY/org.macosforge.xquartz:0
    Oct  5 09:41:35 mbp-renaud-3 Installer[46985]: Env: COMMAND_MODE=unix2003
    Oct  5 09:41:35 mbp-renaud-3 Installer[46985]: Env: __CHECKFIX1436934=1
    Oct  5 09:41:35 mbp-renaud-3 Installer[46985]: Env: __CF_USER_TEXT_ENCODING=0x1F5:0:1
    Oct  5 09:41:35 mbp-renaud-3 Installer[46985]: OpenMono-v1.7.3-Mac  Installation Log
    Oct  5 09:41:35 mbp-renaud-3 Installer[46985]: Opened from: /Users/Admin/Downloads/OpenMono-v1.7.3-Mac.pkg
    Oct  5 09:41:35 mbp-renaud-3 Installer[46985]: Referenced component packages (1) trustLevel=202
    Oct  5 09:41:37 mbp-renaud-3 Installer[46985]: InstallerStatusNotifications plugin loaded
    Oct  5 09:41:41 mbp-renaud-3 runner[46988]: Administrator authorization granted.
    Oct  5 09:41:41 mbp-renaud-3 Installer[46985]: ================================================================================
    Oct  5 09:41:41 mbp-renaud-3 Installer[46985]: User picked Standard Install
    Oct  5 09:41:41 mbp-renaud-3 Installer[46985]: Choices selected for installation:
    Oct  5 09:41:41 mbp-renaud-3 Installer[46985]: 	Installation: "OpenMono-v1.7.3-Mac"
    Oct  5 09:41:41 mbp-renaud-3 Installer[46985]: 		OpenMono-v1.7.3-Mac.pkg : com.openmono.monoframework : 1.7.3
    Oct  5 09:41:41 mbp-renaud-3 Installer[46985]: ================================================================================
    Oct  5 09:41:41 mbp-renaud-3 Installer[46985]: It took 0.00 seconds to summarize the package selections.
    Oct  5 09:41:41 mbp-renaud-3 Installer[46985]: -[IFPKGDerivedDocument sortedPackageLocations]: result = (
    	    "file://localhost"
    	)
    Oct  5 09:41:41 mbp-renaud-3 Installer[46985]: -[IFDInstallController(Private) _buildInstallPlan]: location = file://localhost
    Oct  5 09:41:41 mbp-renaud-3 Installer[46985]: -[IFDInstallController(Private) _buildInstallPlan]: file://localhost/Users/Admin/Downloads/OpenMono-v1.7.3-Mac.pkg
    Oct  5 09:41:41 mbp-renaud-3 Installer[46985]: Set authorization level to root for session
    Oct  5 09:41:41 mbp-renaud-3 Installer[46985]: Will use PK session
    Oct  5 09:41:41 mbp-renaud-3 Installer[46985]: Starting installation:
    Oct  5 09:41:41 mbp-renaud-3 Installer[46985]: Configuring volume "Macintosh HD"
    Oct  5 09:41:41 mbp-renaud-3 Installer[46985]: Preparing disk for local booted install.
    Oct  5 09:41:41 mbp-renaud-3 Installer[46985]: Free space on "Macintosh HD": 8,87 Go (8866820096 bytes).
    Oct  5 09:41:41 mbp-renaud-3 Installer[46985]: Create temporary directory "/var/folders/vt/kc9wgclx3jv0z0_0s83f9b8m0000gn/T//Install.46985yfNgcf"
    Oct  5 09:41:41 mbp-renaud-3 Installer[46985]: IFPKInstallElement (1 packages)
    Oct  5 09:41:41 mbp-renaud-3 Installer[46985]: Using authorization level of root for IFPKInstallElement
    Oct  5 09:41:41 mbp-renaud-3 installd[5345]: PackageKit: Adding client PKInstallDaemonClient pid=46985, uid=501 (/System/Library/CoreServices/Installer.app/Contents/MacOS/Installer)
    Oct  5 09:41:41 mbp-renaud-3 Installer[46985]: PackageKit: Enqueuing install with boosting
    Oct  5 09:41:41 mbp-renaud-3 installd[5345]: PackageKit: ----- Begin install -----
    Oct  5 09:41:41 mbp-renaud-3 installd[5345]: PackageKit: request=PKInstallRequest <1 packages, destination=/>
    Oct  5 09:41:41 mbp-renaud-3 installd[5345]: PackageKit: packages=(
    	    "PKLeopardPackage <file://localhost/Users/Admin/Downloads/OpenMono-v1.7.3-Mac.pkg>"
    	)
    Oct  5 09:41:42 mbp-renaud-3 installd[5345]: PackageKit: Extracting file://localhost/Users/Admin/Downloads/OpenMono-v1.7.3-Mac.pkg (destination=/var/folders/zz/zyxvpxvq6csfxvn_n0000000000000/C/PKInstallSandboxManager/3562B47B-2460-4200-B11B-5577B7C72EEE.activeSandbox/Root, uid=0)
    Oct  5 09:41:45 mbp-renaud-3 installd[5345]: PackageKit: prevent user idle system sleep
    Oct  5 09:41:45 mbp-renaud-3 installd[5345]: PackageKit: suspending backupd
    Oct  5 09:41:45 mbp-renaud-3 installd[5345]: PackageKit: Using trashcan path /var/folders/zz/zyxvpxvq6csfxvn_n0000000000000/T/PKInstallSandboxTrash/3562B47B-2460-4200-B11B-5577B7C72EEE.sandboxTrash for sandbox /var/folders/zz/zyxvpxvq6csfxvn_n0000000000000/C/PKInstallSandboxManager/3562B47B-2460-4200-B11B-5577B7C72EEE.activeSandbox
    Oct  5 09:41:45 mbp-renaud-3 installd[5345]: PackageKit: Shoving /var/folders/zz/zyxvpxvq6csfxvn_n0000000000000/C/PKInstallSandboxManager/3562B47B-2460-4200-B11B-5577B7C72EEE.activeSandbox/Root (2 items) to /
    Oct  5 09:41:45 mbp-renaud-3 installd[5345]: PackageKit: Executing script "./postinstall" in /private/tmp/PKInstallSandbox.a8JjQU/Scripts/com.openmono.monoframework.r6pnCX
    Oct  5 09:41:45 mbp-renaud-3 installd[5345]: ./postinstall: Searching for pyserial
    Oct  5 09:41:45 mbp-renaud-3 installd[5345]: ./postinstall: Reading http://pypi.python.org/simple/pyserial/
    Oct  5 09:41:45 mbp-renaud-3 Installer[46985]: LSExceptions [0x7f9dda408f00] unloaded
    Oct  5 09:41:45 mbp-renaud-3 installd[5345]: ./postinstall: Couldn't find index page for 'pyserial' (maybe misspelled?)
    Oct  5 09:41:45 mbp-renaud-3 installd[5345]: ./postinstall: Scanning index of all packages (this may take a while)
    Oct  5 09:41:45 mbp-renaud-3 installd[5345]: ./postinstall: Reading http://pypi.python.org/simple/
    Oct  5 09:41:46 mbp-renaud-3 installd[5345]: ./postinstall: No local packages or download links found for pyserial
    Oct  5 09:41:46 mbp-renaud-3 installd[5345]: ./postinstall: error: Could not find suitable distribution for Requirement.parse('pyserial')
    Oct  5 09:41:46 mbp-renaud-3 installd[5345]: PackageKit: releasing backupd
    Oct  5 09:41:46 mbp-renaud-3 installd[5345]: PackageKit: allow user idle system sleep
    Oct  5 09:41:46 mbp-renaud-3 installd[5345]: PackageKit: Install Failed: Error Domain=PKInstallErrorDomain Code=112 "Une erreur s’est produite pendant l’exécution des scripts du paquet « OpenMono-v1.7.3-Mac.pkg »." UserInfo=0x7fcb01507250 {NSFilePath=./postinstall, NSURL=file://localhost/Users/Admin/Downloads/OpenMono-v1.7.3-Mac.pkg, PKInstallPackageIdentifier=com.openmono.monoframework, NSLocalizedDescription=Une erreur s’est produite pendant l’exécution des scripts du paquet « OpenMono-v1.7.3-Mac.pkg ».} {
    	    NSFilePath = "./postinstall";
    	    NSLocalizedDescription = "Une erreur s\U2019est produite pendant l\U2019ex\U00e9cution des scripts du paquet \U00ab\U00a0OpenMono-v1.7.3-Mac.pkg\U00a0\U00bb.";
    	    NSURL = "file://localhost/Users/Admin/Downloads/OpenMono-v1.7.3-Mac.pkg";
    	    PKInstallPackageIdentifier = "com.openmono.monoframework";
    	}
    Oct  5 09:41:46 mbp-renaud-3 Installer[46985]: install:didFailWithError:Error Domain=PKInstallErrorDomain Code=112 "Une erreur s’est produite pendant l’exécution des scripts du paquet « OpenMono-v1.7.3-Mac.pkg »." UserInfo=0x7f9dda7a93f0 {NSFilePath=./postinstall, NSURL=file://localhost/Users/Admin/Downloads/OpenMono-v1.7.3-Mac.pkg, PKInstallPackageIdentifier=com.openmono.monoframework, NSLocalizedDescription=Une erreur s’est produite pendant l’exécution des scripts du paquet « OpenMono-v1.7.3-Mac.pkg ».}
    Oct  5 09:41:46 mbp-renaud-3 installd[5345]: PackageKit: Running idle tasks
    Oct  5 09:41:46 mbp-renaud-3 installd[5345]: PackageKit: Removing client PKInstallDaemonClient pid=46985, uid=501 (/System/Library/CoreServices/Installer.app/Contents/MacOS/Installer)
    Oct  5 09:41:46 mbp-renaud-3 installd[5345]: PackageKit: Done with sandbox removals
    Oct  5 09:41:47 mbp-renaud-3 Installer[46985]: Install failed: Le programme d’installation a rencontré une erreur qui a provoqué l’échec de l’installation. Contactez l’éditeur du logiciel pour obtenir de l’aide.
    Oct  5 09:41:47 mbp-renaud-3 Installer[46985]: IFDInstallController DC004A50 state = 8
    Oct  5 09:41:47 mbp-renaud-3 Installer[46985]: Displaying 'Install Failed' UI.
    Oct  5 09:41:47 mbp-renaud-3 Installer[46985]: 'Install Failed' UI displayed message:'Le programme d’installation a rencontré une erreur qui a provoqué l’échec de l’installation. Contactez l’éditeur du logiciel pour obtenir de l’aide.'.
    Oct  5 09:43:40 mbp-renaud-3 softwareupdated (200)[11092]: BackgroundActivity: Starting Background Check Activity
    Oct  5 09:43:41 mbp-renaud-3 softwareupdated (200)[11092]: SoftwareUpdate: Automatic checking disabled
    Oct  5 09:43:41 mbp-renaud-3 softwareupdated (200)[11092]: BackgroundActivity: Finished Background Check Activity
    Oct  5 12:43:56 mbp-renaud-3 softwareupdated (200)[11092]: BackgroundActivity: Starting Background Check Activity
    Oct  5 12:43:56 mbp-renaud-3 softwareupdated (200)[11092]: SoftwareUpdate: Automatic checking disabled
    Oct  5 12:43:56 mbp-renaud-3 softwareupdated (200)[11092]: BackgroundActivity: Finished Background Check Activity
    


  • Hi @renaud,

    The installation fails when it tries to install a python package to enable serial port communication. Our monomake tool uses this python package to trigger a reset of Mono when it you upload new application to it.

    The caused might be a hiccup in the network, so try again (if you have not already). Another reason that I can think of is that the version of Python included in MacOS 10.9.5 is no longer supported by PyPi or easy_install.

    Could you try to run this command in the terminal app:

    $ easy_install --version
    

    It should respond with something like this:

    setuptools 36.0.1 from /usr/local/lib/python2.7/site-packages (Python 2.7)
    

    Install command

    You can also try to the run the command (from the Terminal.app) the installer package runs, that causes the fault:

    $ easy_install -U pyserial
    


  • Hi @stoffera,
    Easy_install is not installed: command not found :((



  • @renaud sorry about the late reply - apparantly my setup reading RSS with ifttt and forwarding notification does not work properly :-/

    Do you have python installed? Try:

    $ python --version
    

    If yes, then then see if pip is installed. (pip is yet another package manager for python)

    $ pip install pyserial
    

    (You might need to be root)



  • Thank you for your help!

    Python 2.7.5

    When I do pip install pyserial:
    -bash: pip: command not found

    pip is not installed.

    When I install pip:
    sudo easy_install pip
    Password:
    Searching for pip
    Reading http://pypi.python.org/simple/pip/
    Couldn't find index page for 'pip' (maybe misspelled?)
    Scanning index of all packages (this may take a while)
    Reading http://pypi.python.org/simple/
    No local packages or download links found for pip
    error: Could not find suitable distribution for Requirement.parse('pip')



  • @renaud said in Installation issue on Mac OS 10.9.5:

    Hi @stoffera,
    Easy_install is not installed: command not found :((

    I am a bit confused, now easy_install are present? Can you do a:

    $ sudo easy_install pyserial
    

    (skip the -U that I included in an earlier post - also you need to be sudo)



  • I cannot install pyserial :(

    ~ Admin$ sudo easy_install pyserial
    Searching for pyserial
    Reading http://pypi.python.org/simple/pyserial/
    Couldn't find index page for 'pyserial' (maybe misspelled?)
    Scanning index of all packages (this may take a while)
    Reading http://pypi.python.org/simple/
    No local packages or download links found for pyserial
    error: Could not find suitable distribution for Requirement.parse('pyserial')



  • hi @renaud I can't seem to make sense of why your python installation will not instal pyserial.

    From the output you provided:

    Reading http://pypi.python.org/simple/pyserial/
    

    The link works - so easy_install should be able to find the package.

    Well, perhaps you need to upgrade from Mavericks to something newer - or you could try to install pyserial manually here: Pyserial


Log in to reply