Issue with 1.7 install on debian

  • install files seems to be missing in the debian package, see below:

  • The package openmono_1.7.0.deb of this release seems to be missing many files which are supposed to be installed to directory /usr/lib/openmono/mono.

    Because of this, building an app does not work, and even the example hello_world exits with error:

    make: *** No rule to make target /usr/lib/openmono/mono/monoCyLib.a', needed by 'hello_world.elf'. Stop.

    (The file monoCyLib.a is missing from filesystem, along with whole directory /usr/lib/openmono/mono).

  • @malaire This was caused by a bug in the debian build system. I have uploaded a new build of the debian package:

  • Still same error. Running dpkg-deb -c openmono_1.7.0.deb | grep monoCyLib shows nothing, i.e. the required file is not included anywhere in the package.

  • Hi @malaire, you are right - I guess the last build went too through to swiftly. I have now found a bug in the package build script that caused copying of the mono directory to fail. I have fixed it now and uploaded a new build on the GitHub release site.

    I have tested the new build inside a Debian jessie Docker container, and it works.

    I am sorry about the repeated inconvenience. And thank you for your effort and feedback.

  • Thanks, it's working now on Debian Stretch.

    ps. sudo apt-get purge modemmanager is still needed as that keeps resetting Mono.

  • @malaire We are rolling out a version 1.7.1 in the next day or two, that marks the package modemmanager as a Conflict. This means it must be uninstalled before openmono can be installed.

    We think this is the correct approach, because it uses the dkpg system to document the relationship. Also, it is left as a user choice. We want to avoid removing packages from a users system by default.

Log in to reply