Cannot install app after the first one



  • @_gid OK, something seems yo be cause Mono not to reset or monoprog times out before mono has booted the bootloader.

    Try to see if you can reset Mono using the USB Serial DTR line:

    $ monomake reboot
    

    A Mono running the "hello world" app should reset when running this command. Can you see if Mono resets?



  • It doesn't seem to do anything...

    bash-3.2$ monomake reboot
    using port: /dev/cu.usbmodem1D111
    bash-3.2$ 
    

    and the screen just continues to say Hi, I'm Mono! without a flicker. And, just in case this helps:

    bash-3.2$ monomake bootldr
    Mono device running app detected.
    bash-3.2$ 
    

    I've just managed to fix my MacBook Pro that's running El Capitan, so I can try that shortly.



  • I've verified the same behaviour on my MacBook Pro, running El Capitan. It has never had the device plugged in or the SDK installed.

    I installed OpenMono-v1.2-Mac.pkg, ran monomake project hello_world; make; make install and it failed in the same way.

    I performed a "Force Bootloader" and make install worked.

    A second make install failed in the same way.



  • Seeing the same behavior here macOS Sierra, mono SDK 1.2.



  • Hi @_gid & @allan

    I found out it seems to be an issue introduced in SDK 1.2!
    Could you try to upgrade to the coming 1.3 release

    Let me know if it helps

    /kristoffer



  • @stoffera That seems to have fixed it, thanks.

    To clarify, it didn't work with the existing SDK 1.2 compiled app installed, so I did a button + reset restart, then make install, and then a subsequent make install and it worked.



  • SDK 1.3 fixed it for me.



  • HI @allan & @_gid ,

    The SDK 1.3 you tried mistakenly announces itself (monomake version) as version 1.2.1 on Mac. (Things went a little fast Tuesday)

    I have uploaded a new build of the package (same link as previous)



  • @stoffera hah, it sure does. I hadn't noticed :)


Log in to reply