make install fails (dylib not found)

  • Back again with another 'getting started' headache, I'm afraid.

    $ make install
    Compiling C++: Default main function
    Linking hallowelt.elf
    Programming app to device...
    /usr/local/openmono/monoprog/ -p hallowelt.elf --verbose 1
    dyld: Library not loaded: /Developer/Qt/5.4/clang_64/lib/QtSerialPort.framework/Versions/5/QtSerialPort
      Referenced from: /usr/local/openmono/monoprog/
      Reason: image not found
    make: *** [install] Trace/BPT trap: 5
    • I definitely have a mono connected and powered on.
    • It's possible I need to install the Qt libs separately.
    • I don't have a /Developer on this Mac, though I do have Xcode and (AFAIK) the cli tools.


  • @pktm Again, sorry for the inconvenience!

    I have uploaded a new release of the mac installer with a working Monoprog. (where QtSerialPort.dylib is included)

    Or download here:

  • @stoffera Yeah that's the one I downloaded this morning, but I'm still getting that error.

    $ monomake version
    monomake version 1.1.2

    Sorry. I realize I'm being 'that guy' but I guess that's just who I am at the moment. Haha.

  • @pktm said in make install fails (dylib not found):

    the one I downloaded this morning, but I'm still getting that error.

    Ouch, still the: dyld: Library not loaded error? I have tried the installer on 2 different fresh Mac OS X installs (Lion & El Capitan) - and it works.

  • @stoffera I'm on 10.10.5 (Yosemite). What other diagnostic information can I offer to help track this down for you/us?

  • Have run my most recent Mac OS installer (this link), v1.1.3 ?

    If yes, then try this uninstall script:

    $ sudo rm -rf /usr/local/openmono
    $ sudo rm /usr/local/bin/monomake

    And install again.

    If none if this helps, please check for what is present in: /usr/local/openmono/monoprog/

    $ ls -l /usr/local/openmono/monoprog/

  • @stoffera Ok, I think that fixed it! I'll do a bit more work with this today. Thanks!

Log in to reply